ANC - is temporarily unavailable for purchase.
Incident Report for ChangeNow
Update
Our team is still working on it, we’ll keep you updated.
Posted Jun 07, 2022 - 01:05 UTC
Update
Our team is still working on it, we’ll keep you updated.
Posted Jun 05, 2022 - 20:37 UTC
Update
Our team is still working on it, we’ll keep you updated. ETA is 2022-06-06
Posted Jun 04, 2022 - 23:32 UTC
Update
Our team is still working on it, we’ll keep you updated. ETA is 2022-06-06.
Posted Jun 04, 2022 - 00:09 UTC
Update
Our team is still working on it, we’ll keep you updated. ETA is 2022-06-06.
Posted Jun 03, 2022 - 18:44 UTC
Update
ANC is temporarily unavailable for purchase due to some issues on the liquidity provider side. ETA is 2022-06-06.
Posted Jun 03, 2022 - 15:08 UTC
Identified
Our team is already working on it, we’ll keep you updated.
Posted Jun 03, 2022 - 15:03 UTC