Delays with USDTTRC20 payouts processing
Incident Report for ChangeNow
Resolved
Today from 11:00 to 00:30 UTC we were experiencing delays with USDTTRC20 payouts processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Sep 19, 2022 - 00:44 UTC
Update
Unfortunately, we are still experiencing delays with USDTTRC20 payouts processing.

At the moment the team is working on the restoration of the service.
We will be back with an update within 5 hours.
Posted Sep 18, 2022 - 21:24 UTC
Update
Unfortunately, we are still experiencing delays with USDTTRC20 payouts processing.
At the moment the team is working on the restoration of the service. We will be back with an update within 3 hours.
Posted Sep 18, 2022 - 18:53 UTC
Monitoring
From 11:00 AM (UTC) we are experiencing issues with USDTTRC20 payouts processing.
Our technical team is already working on a fix.
Posted Sep 18, 2022 - 12:18 UTC
This incident affected: Digital Assets (Tether (TRC20) (USDTTRC20)).