Possible delays with XMR exchanges processing.
Incident Report for ChangeNow
Resolved
Today from 15:30 to 18:00 UTC, we were experiencing possible delays with XMR exchanges processing.

We are happy to announce that the issue has been successfully resolved, and all affected exchanges will be processed as soon as possible.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Mar 25, 2024 - 18:23 UTC
Investigating
From 15:30 UTC, we are experiencing possible delays with XMR exchange processing.
As a result, users may notice no status change on the exchange page.

Our technical team is working on a solution.
We will get back to you with updates as soon as possible.
Posted Mar 25, 2024 - 15:48 UTC
This incident affected: Digital Assets (Monero (XMR)).