Temporary issues with deposit recognition
Incident Report for ChangeNow
Resolved
From 12:20 UTC to 13:20 UTC we were experiencing issues with recognizing users' deposits.

We are happy to announce that the problem has been successfully resolved and the team is processing all affected exchanges.

There still might be delays with SOL deposit recognition. Our team is working on it.

At the moment the service is working as usual, but if you are still experiencing this issue, please let us know.
We sincerely apologize for the inconvenience caused.
Posted May 31, 2024 - 13:21 UTC
Investigating
From 12:20 UTC we are experiencing issues with recognizing users' deposits.

As a result, users may notice no status change from "awaiting deposit" to "confirming" on the exchange page after sending the deposit.
Our technical team is investigating the cause and is already working on a solution.

We will get back to you with an update as soon as we receive any news from the team.
Posted May 31, 2024 - 12:30 UTC
This incident affected: Digital Assets (Ethereum (ETH), Monero (XMR), Optimism (OP), Pulsechain (PLS) (PLS), BNB Smart Chain (BNBBSC), Solana (SOL), Polygon (Matic) (MATIC), Terra (LUNA), Bitcoin (BTC)).