Temporary delays with processing partner withdrawals
Incident Report for ChangeNow
Resolved
From 12:30 to 13:35 UTC we were experiencing delays with processing payouts and partner withdrawals.

We are happy to announce that the problem has been successfully resolved, and the team is processing affected exchanges and withdrawals.
The issue occurred due to inter-server communication failure.

We sincerely apologize for the inconvenience caused.
Posted Nov 29, 2024 - 13:42 UTC
Investigating
Hi all,
Since 12:30 UTC, we’ve noticed some temporary delays with processing payouts and partner withdrawals.

Our tech team is investigating and actively working on a solution. We’ll keep you posted and share an update within the next several hours.

Thanks for your understanding!
Posted Nov 29, 2024 - 13:01 UTC
This incident affected: Withdrawals.