Delays in recognizing deposits and delays with processing XMR payouts

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 12:16 UTC

Identified

The issue has been identified and a fix is being implemented.
There may be delays in recognizing deposits at these networks:

kas
avaxc
band
fil
ton

Our tech team is on it and already working on a fix.

We’ll update you within several hours. Thanks for hanging in there!
Posted Jun 23, 2025 - 11:55 UTC

Investigating

Hello!
Since 11:00 UTC, we're having some delays in recognizing deposits and with processing XMR payouts. The issue occurred due to delays in updating data on the current liquidity balance on our side.

Because of that, you might see the status stuck on "waiting" or "sending to you" and it won't update.
Our tech team is on it and already working on a fix.

We’ll update you within several hours. Thanks for hanging in there!
Posted Jun 23, 2025 - 11:30 UTC
This incident affected: Deposits.