Today, from 06:25 to 08:00 (UTC), there was scheduled technical maintenance by our liquidity provider.
We are happy to announce that the technical maintenance has been successfully completed.
At the moment, the service is working as usual.
Posted May 09, 2025 - 16:14 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 09, 2025 - 06:25 UTC
Scheduled
Hello there, Just a quick heads-up: on May 9, starting at 06:25 (UTC), we might experience temporary delays with TRX and TRC20 token payouts due to scheduled maintenance by our liquidity provider.
During this time, you may notice that the status on the exchange page stays stuck on "exchanging" or "sending to you." Rest assured, assets won’t be disabled, and all affected exchanges will be processed as usual.
We’ll keep you updated and let you know once everything is back to normal. Thanks for your understanding, and we apologize for any inconvenience this may cause!
Posted May 08, 2025 - 09:30 UTC
This scheduled maintenance affected: Digital Assets (Tether (TRC20) (USDTTRC20), TRON (TRX), Sun (SUN), BitTorrent-New (TRC 20) (BTTC), WINkLink (Tron) (WINTRC20), TrueUSD (Tron) (TUSDTRC20), JUST (JST)).