We are experiencing temporary issues with the processing of BTC exchanges due to the delay of a new block of the network
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 16:20 UTC
Identified
From 13:30 UTC we are experiencing temporary issues with the processing of BTC exchanges due to the delay of a new block of the network.

As a result, there may be delays in updating statuses on the affected exchanges page.
Once a new block is created, all deposits and exchanges will be processed as usual.
You can also check up-to-date information about the BTC network by following the link:
https://www.blockchain.com/btc/blocks?page=1

We will provide an additional update as soon as a new block is created.
Posted Jul 24, 2024 - 15:47 UTC
This incident affected: Digital Assets (Bitcoin (BTC)).