Delays with XMR payouts processing
Incident Report for ChangeNow
Resolved
We have successfully eliminated the delays with XMR payouts processing. Please let us know if you experience any delays.
Posted Sep 18, 2022 - 18:41 UTC
Monitoring
From 01:00 PM (UTC) we are experiencing issues with XMR payouts processing.
Our technical team is already working on a fix.
Posted Sep 18, 2022 - 17:57 UTC
This incident affected: Digital Assets (Monero (XMR)).