Delays with ETHW payouts processing
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Sep 17, 2022 - 14:44 UTC
Investigating
From 11:00 AM (UTC) we are experiencing issues with ETHW payouts processing.
Our technical team is already working on a fix.
Posted Sep 17, 2022 - 13:59 UTC
This incident affected: Digital Assets (ETHPoW (ETHW)).