Some issues with processing ADA and AVAXC payouts

Incident Report for ChangeNow

Resolved

Today from 16:30 UTC to 19:50 UTC we were experiencing delays with ADA payouts processing.

We are happy to announce that the problem has been successfully resolved.
To sum it up both issues with ADA and AVAXC payouts were resolved.
At the moment the service is working as usual, but if you are still experiencing this issue, please let us know.

We sincerely apologize for the inconvenience caused.
Posted Mar 02, 2025 - 19:59 UTC

Identified

Since 16:30 UTC to 18:45 UTC, we had some issues with processing AVAXC payouts. Good news — the issue with AVAXC payouts has been sorted, and all the affected payouts have been processed.
Our team is still working on the ADA payout processing delays. Once we get an update on that - we will provide separate notification as well.
Thank you for your patience and understanding!
Posted Mar 02, 2025 - 18:56 UTC

Investigating

Hello!
Since 16:30 UTC, we're having some issues with processing ADA and AVAXC payouts.

Because of that, you might see the status stuck on "sending to you" and it won't update.
Our tech team is on it and already working on a fix.

We’ll update you within several hours. Thanks for hanging in there!
Posted Mar 02, 2025 - 17:00 UTC
This incident affected: Digital Assets (Cardano (ADA), Avalanche (C-Chain) (AVAXC)).