We are experiencing delays with processing USDTTRC20 payouts

Incident Report for ChangeNow

Resolved

From 17:50 until 18:45 UTC we were experiencing delays with processing USDTTRC20 payouts due to the increase in network commission. We are glad to inform you that the issue has been resolved and all the affected exchanges have been processed!
Posted Oct 17, 2025 - 18:54 UTC

Identified

Hi! From 17:50 UTC we are experiencing delays with processing USDTTRC20 payouts due to the increase in network commission. Our team is already on it and we will provide updates as soon as possible!
Posted Oct 17, 2025 - 18:11 UTC
This incident affected: Exchange Processing and Digital Assets (Tether (TRC20) (USDTTRC20)).