We are experiencing delays with payouts

Incident Report for ChangeNow

Resolved

From 18:50 UTC until 19:05 we had temporary delays with processing payouts. The delays has occurred because of issues with internal servers connectivity.

Good news is, the issue was resolved and all the affected exchanges has been processed.

We thank you for your patience and understanding!
Posted Jan 21, 2026 - 19:09 UTC

Identified

Hello! From 18:50 UTC we are experiencing issues with submitting payouts. Our team is already reviewing the issue and we will notify you once it will be resolved.

We apologize for the inconvenience.
Posted Jan 21, 2026 - 18:56 UTC
This incident affected: Exchange Processing.