We are experiencing delays with processing BCH exchanges

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 04:31 UTC

Identified

We are currently experiencing delays in processing BCH exchanges due to a network outage affecting the Bitcoin Cash blockchain.

The issue started at 02:00 UTC , and as a result, exchange completion times may be longer than usual.

Our team is closely monitoring the situation and will resume normal processing as soon as the network is stable. We apologize for the inconvenience and appreciate your patience.
Posted Jun 29, 2026 - 04:04 UTC
This incident affected: Withdrawals, Deposits, Exchange Processing and Digital Assets (Bitcoin Cash (BCH)).