Today from 06:00 to 08:20 UTC we were experiencing delays with PLS payouts processing.
We are happy to announce that the issue has been successfully resolved, and PLS exchanges processing without any issues at the moment. The issue occurred due to unscheduled maintenance on the side of the liquidity provider. At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.
We sincerely apologize for the inconvenience caused.
Posted Apr 16, 2025 - 08:31 UTC
Investigating
We would like to notify you that today from 06:00 UTC, we are experiencing delays with PLS payouts processing and partner rewards processing.
In view of this, on the page of affected exchanges, the status "Sending to you" may be updated longer than usual. Our technical team is already working on a solution.
We will get back to you with an update as soon as possible.
Posted Apr 16, 2025 - 07:16 UTC
This incident affected: Digital Assets (Pulsechain (PLS) (PLS)).