Temporary issues with USDC, USDCMATIC and USDCSOL exchanges and payouts processing.
Incident Report for ChangeNow
Resolved
We're glad to notify you that USDC, USDCMATIC, USDCSOL, and USDCBSC are fully operational!

We are happy to announce that the issue with exchanges and payouts processing has been successfully resolved.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.
Posted Mar 14, 2023 - 17:39 UTC
Update
We're glad to notify you that USDC is operational once again. USDCMATIC, USDCSOL and USDCBSC are still under maintenance.

Unfortunately, we are still experiencing issues with USDC exchanges and payouts processing.

We'll come back with an update once there is any news.
Posted Mar 11, 2023 - 12:02 UTC
Update
USDC, USDCMATIC, USDCSOL and USDCBSC are under maintenance due to the current USDC market situation (https://decrypt.co/123208/coinbase-binance-suspend-usdc-conversions-as-dollar-peg-wobbles). Buy & Sell are unavailable.

All affected exchanges will be processed after the restoration of USDC markets.
There is no ETA at this moment due to the above reason.
Posted Mar 11, 2023 - 06:46 UTC
Update
Unfortunately, we are still experiencing issues with USDC, USDCMATIC, USDCSOL and USDCBSC exchanges and payouts processing. The issue is related to the current USDC market situation, you can check more information here - https://decrypt.co/123208/coinbase-binance-suspend-usdc-conversions-as-dollar-peg-wobbles

We'll come back with an update once there is any news.
Posted Mar 11, 2023 - 06:33 UTC
Update
Unfortunately, we are still experiencing issues with USDC, USDCMATIC and USDCSOL exchanges and payouts processing. The problem has also affected exchanges and payouts processing with USDCBSC.

At the moment our team is working on the restoration of the service.
We'll come back with an update within 2 hours.
Posted Mar 11, 2023 - 04:35 UTC
Identified
From 01:00 UTC we are experiencing issues with USDC, USDCMATIC and USDCSOL exchanges and payouts processing.

As a result, users may notice that there is no status change from "exchanging" and from "sending to you" on the exchange page.
The issue occurred due to delays in updating data on the current liquidity balance on our side.
Our technical team is already working on a solution.

We will get back to you with an update within 2 hours.
Posted Mar 11, 2023 - 02:58 UTC
This incident affected: Digital Assets (USD Coin (USDC)).