Temporary delays with TRC20 tokens payouts and partner rewards processing
Incident Report for ChangeNow
Resolved
Hey! Just a heads-up — today, between 08:00 and 10:45 UTC, we had some delays with processing TRX and TRC20 tokens payouts and partner rewards processing.

Good news though — the issue has been sorted. Everything’s back to normal now, but if you're still having trouble, please let us know.

Sorry for the hassle, and thanks for your patience!
Posted Nov 14, 2024 - 11:03 UTC
Investigating
Hello!
Since 08:00 UTC, we're having some issues with processing TRX and TRC20 tokens payouts and partner rewards processing.
Because of that, you might see the status stuck on "sending to you" and it won't update.

Our tech team is on it and already working on a fix.
We’ll update you within several hours. Thanks for hanging in there!
Posted Nov 14, 2024 - 09:06 UTC
This incident affected: Digital Assets (Tether (TRC20) (USDTTRC20), TRON (TRX)).