We may experiencing delays with USDTERC20 payout and partner rewards processing

Incident Report for ChangeNow

Resolved

From 20:30 UTC to 23:00 UTC we were experiencing delays with USDTERC20 payout and partner rewards processing.

The good news — the delays have been sorted now, and all the affected payouts and partner rewards have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please let us know.

We sincerely apologize for the inconvenience caused.
Posted Nov 04, 2025 - 23:07 UTC

Investigating

From 20:30 UTC, we are experiencing delays with USDTERC20 payout and partner rewards processing.

As a result, users may notice that there is no status change from "sending to you" on the exchange page.
Our tech team is on it and already working on a fix.

We’ll update you as soon as we can. Thanks for hanging in there!
Posted Nov 04, 2025 - 21:19 UTC
This incident affected: Digital Assets (Tether (ERC20) (USDTERC20)).