Delays with USDTTRC20 payouts processing
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 17:32 UTC
Monitoring
From 11:00 AM (UTC) we are experiencing issues with USDTTRC20 payouts processing.

Our technical team has already fixed the problem.
We will get back to you with an update within 1 hour.
Posted Sep 14, 2022 - 12:36 UTC
This incident affected: Digital Assets (Tether (TRC20) (USDTTRC20)).