We are experiencing delays with ZEC exchanges processing

Incident Report for ChangeNow

Resolved

From 01:45 UTC to 01:55 UTC today, we had delays with processing ZEC exchanges.

Good news though — the issue has been sorted, and all the affected payouts have been processed. Everything’s back to normal now, but if you're still having trouble, please let us know.

Sorry for the hassle, and thanks for your patience!
Posted Dec 01, 2025 - 02:52 UTC

Identified

Hi. From 01:45 UTC, we are experiencing issues with ZEC exchanges processing.

As a result, users may notice that there is no status change from "exchanging" on the exchange page.
Our tech team is on it and already working on a fix.

We’ll update you as soon as we can. Thanks for hanging in there!
Posted Dec 01, 2025 - 01:56 UTC
This incident affected: Exchange Processing and Digital Assets (Zcash (ZEC)).