We are experiencing temporary issues with the creation of exchanges and estimated amounts
Incident Report for ChangeNow
Resolved
From 09:10 UTC to 10:00 UTC, we were experiencing temporary issues with the creation of exchanges and estimated amounts, as well as the ChangeNOW PRO account availability.

The issue occurred due to inter-server communication failure.

We sincerely apologize for the inconvenience caused.
Posted May 28, 2024 - 10:04 UTC
Investigating
From 09:10 UTC, we are experiencing temporary issues with the creation of exchanges and estimated amounts, as well as the ChangeNOW PRO account availability.

Our technical team is investigating the cause and is already working on a solution.

We will get back to you with an update as soon as we receive any news from the team.
Posted May 28, 2024 - 09:20 UTC
This incident affected: Website (Website, User Profile).