Delays with USDTTRC20 payouts processing

Incident Report for ChangeNow

Resolved

We are happy to announce that issues with USDTTRC20 were successfully eliminated.

All affected exchanges were successfully completed, and our service is currently operating as usual.
If you are still experiencing this issue or its consequences, please let us know.

We sincerely apologize for the inconvenience caused.
Posted Oct 10, 2025 - 15:43 UTC

Investigating

Starting at 14:35 UTC we are experiencing issues with USDTTRC20 payouts processing.

In this regard, the page of the affected exchanges temporarily displays the status "sending to you".

The team is investigating the reasons at this moment. We will get back to you with new information soon.
Posted Oct 10, 2025 - 14:55 UTC
This incident affected: Digital Assets (Tether (TRC20) (USDTTRC20)).