Partner rewards and balances issue
Incident Report for ChangeNow
Resolved
Today from 6:30 AM UTC until 9:30 AM UTC we were experiencing delays with partner reward processing and partner's balances top-up.
The issue occurred due to delays with the synchronization of services responsible for operations.

We are happy to announce that the issue has been successfully resolved.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.
We sincerely apologize for the inconvenience caused.
Posted May 25, 2023 - 09:39 UTC
Investigating
Today from 6:30 AM UTC we are experiencing delays with partner reward processing and partner's balances top-up.

The team is already investigating the issue and working on a solution. We will get back with an update within 4 hours.
We apologize for the inconvenience caused
Posted May 25, 2023 - 07:57 UTC
This incident affected: Withdrawals.