Temporary delays with BTC exchanges
Incident Report for ChangeNow
Resolved
Today, from 17:50 to 19:00 UTC, we were experiencing temporary issues with the processing of BTC exchanges due to the delay of a new block of the network.

We are happy to announce that a new BTC block was created, and all affected exchanges have been processed.
At the moment, the service is working as usual, but if you are still experiencing any issues, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Jan 16, 2025 - 19:02 UTC
Identified
Hello!
We’re currently experiencing some temporary delays with BTC exchanges, starting from 17:50 UTC, due to a delay in the latest block on the network.

This means that you may notice delays in status updates on the affected exchanges page. Once the new block is created, everything will process as normal.

You can stay updated on the BTC network by checking this link: https://www.blockchain.com/btc/blocks?page=1.

We’ll send out another update as soon as the new block is confirmed. Thanks for your understanding!
Posted Jan 16, 2025 - 18:03 UTC
This incident affected: Digital Assets (Bitcoin (BTC)).