Temporary issues with the processing of BTC exchanges
Incident Report for ChangeNow
Resolved
Today from 20:00 to 20:20 UTC we were experiencing temporary issues with the processing of BTC exchanges due to the delay of a new block of the network.

We are happy to announce that a new BTC block was created, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing any issues, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Sep 17, 2022 - 20:25 UTC
Investigating
From 20:00 UTC we are experiencing temporary issues with the processing of BTC exchanges due to the delay of a new block of the network.
As a result, there may be delays in updating statuses on the affected exchanges page.
Once a new block will be created, all deposits and exchanges will be processed as usual.

You can also check up-to-date information about the BTC network by following the link: https://www.blockchain.com/btc/blocks?page=1
We will provide an additional update as soon as a new block will be created.
Posted Sep 17, 2022 - 20:10 UTC
This incident affected: Digital Assets (Bitcoin (BTC)).