We are experiencing issues with SOL payouts processing.
Incident Report for ChangeNow
Resolved
Today from 13:40 UTC to 14:55 UTC, we were experiencing issues with SOL payouts processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
At the moment, the service is working as usual, but if you are still experiencing this issue, please let us know.
Posted Mar 30, 2024 - 14:56 UTC
Identified
From 13:40 UTC, we are experiencing issues with SOL payouts processing.

As a result, users may notice that there is no status change from "sending to you" on the exchange page.
The issue occurred due to a highly increased load on the coin network. Our technical team is already working on a solution.
Posted Mar 30, 2024 - 14:28 UTC
This incident affected: Exchange Processing and Digital Assets (Solana (SOL)).