Today from 13:30 to 18:00 UTC we were experiencing delays with processing SUI payouts.
We are happy to announce that the issue has been successfully resolved, and exchanges processing without any issues at the moment. The issue occurred due to a malfunction in communication between internal services.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.
We sincerely apologize for the inconvenience caused.
Posted Jun 10, 2025 - 18:08 UTC
Investigating
Hello! Since 13:30 UTC, we're having some issues with processing SUI payouts.
Because of that, you might see the status stuck on "sending to you" and it won't update. Our tech team is on it and already working on a fix.
We’ll update you within several hours. Thanks for hanging in there!
Posted Jun 10, 2025 - 17:41 UTC
This incident affected: Digital Assets (Sui (SUI)).