We are experiencing issues with ETH payouts processing.
Incident Report for ChangeNow
Resolved
From 7:30 PM to 8:30 UTC we were experiencing issues with ETH payouts processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
The issue happened due to increased fees in the coin network.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted May 15, 2023 - 20:37 UTC
Investigating
From 7:30 PM UTC we are experiencing issues with ETH payouts processing.

As a result, users may notice that there is no status change from "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.

We will get back to you with an update as soon as we receive any news from the team.
Posted May 15, 2023 - 19:49 UTC
This incident affected: Digital Assets (Ethereum (ETH)) and Exchange Processing.