Temporary delays with XMR exchanges processing.
Incident Report for ChangeNow
Resolved
Today from 19:10 to 23:40 UTC, we were experiencing possible delays with XMR exchanges processing.

We are happy to announce that the issue has been successfully resolved, and all affected exchanges will be processed as soon as possible.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Mar 25, 2024 - 23:41 UTC
Identified
From 19:10 UTC, we are experiencing delays with XMR exchanges processing.
The issue occurred due to unscheduled maintenance on our liquidity provider’s side.
As a result, users may notice no status change on the exchange page.

Our technical team is working on a solution.
We will get back to you with updates as soon as possible.
Posted Mar 25, 2024 - 19:29 UTC
This incident affected: Exchange Processing and Digital Assets (Monero (XMR)).