We are experiencing issues with BSC tokens partner rewards processing

Incident Report for ChangeNow

Resolved

Hey! Just a heads-up — today, between 16:10 and 17:30 UTC, we had some delays with BSC tokens partner rewards processing.

Good news though — the issue has been sorted, and all the affected payouts have been processed. Everything’s back to normal now, but if you're still having trouble, please let us know.

Sorry for the hassle, and thanks for your patience!
Posted Feb 04, 2026 - 17:36 UTC

Investigating

From 16:10 UTC, we are experiencing issues with BSC tokens partner rewards processing.

As a result, partners may notice that there is no status change from "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.

We will get back to you with an update as soon as the issue is resolved.
Posted Feb 04, 2026 - 16:44 UTC
This incident affected: Withdrawals.