Temporary issues with ETHARB exchanges and payouts processing.
Incident Report for ChangeNow
Resolved
Today from 18:10 to 21:40 UTC we were experiencing delays with ETHARB exchanges and payouts processing.

We are happy to announce that the issue with exchanges and payouts processing has been successfully resolved. All affected exchanges will be completed by the team.
The issue occurred due to a highly increased load on the payment service, which created a queue of payouts in the coin.

At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.
Posted Mar 23, 2023 - 22:37 UTC
Investigating
From 18:10 UTC we are experiencing issues with ETHARB exchanges and payouts processing.

As a result, users may notice that there is no status change from "exchanging" and from "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.

We will get back to you with an update within 4 hours.
Posted Mar 23, 2023 - 19:43 UTC