Temporary delays with payouts processing

Incident Report for ChangeNow

Resolved

Since 03:00 UTC to 04:30 UTC, we had some issues with payouts processing.

We are happy to announce that the problem has been successfully resolved. At the moment the service is working as usual, but if you are still experiencing this issue, please let us know.

We sincerely apologize for the inconvenience caused.
Posted Sep 25, 2026 - 04:35 UTC

Investigating

From 03:00 UTC we are experiencing delays with payouts processing.

Because of that, you might see the status stuck on "sending to you" and it won't update.
Our tech team is on it and already working on a fix.

We will get back to you with an update as soon as we get any news.
Posted Sep 25, 2026 - 03:11 UTC
This incident affected: Withdrawals and Exchange Processing.