We've been experiencing some issues with processing on the exchanges

Incident Report for ChangeNow

Resolved

Hey!
Today, between 14:10 and 16:00 UTC, we experienced some delays with exchanges processing.

We're happy to let you know that the issue has now been fully resolved, and all affected exchanges have been processed. Everything is back to normal, but if you're still facing any issues, please don't hesitate to reach out.

We truly apologize for any inconvenience this may have caused and appreciate your patience!
Posted Mar 29, 2025 - 16:03 UTC

Identified

We’ve figured out what’s causing the delay with exchanges processing. The issue occurred due to a high system load.

Our tech team is already on it. We expect to have it resolved in about 60 minutes.
Posted Mar 29, 2025 - 15:36 UTC

Investigating

Hello!
Since 14:10 UTC, we've been experiencing some issues with processing on the exchanges.

This means that you might see the status stuck on 'exchanging' on the exchange page. Our tech team is already looking into it and working on a fix.

We'll keep you updated and let you know as soon as we have more info, which should be in about 60 minutes.
Posted Mar 29, 2025 - 14:25 UTC
This incident affected: Exchange Processing.