Delays with payouts processing
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 15:03 UTC
Investigating
From 01:10 PM (UTC) we are experiencing issues with payouts processing. Our technical team is investigating the cause and is already working on a solution.
We will get back to you with an update within 2 hours.
Posted Sep 09, 2022 - 13:52 UTC
This incident affected: Withdrawals.