We are experiencing issues with SOL deposits and payouts processing.
Incident Report for ChangeNow
Resolved
Today from 4:00 PM UTC to 4:35 PM UTC, we were experiencing delays with SOL deposits and payouts processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
The issue occurred due to a highly increased load on the coin network.
At the moment, the service is working as usual, but if you are still experiencing this issue, please let us know.

We sincerely apologize for the inconvenience caused.
Posted Mar 22, 2024 - 16:36 UTC
Investigating
From 04:00 PM UTC, we are experiencing issues with SOL deposits and payouts processing.

As a result, users may notice that there is no status change from "awaiting deposit" and "sending to you" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.

We will get back to you with an update as soon as we get any news from the team.
Posted Mar 22, 2024 - 16:03 UTC
This incident affected: Digital Assets (Solana (SOL)).