We are experiencing temporary issues with the processing of BTC exchanges due to the delay of a new block of the network.

Incident Report for ChangeNow

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 04:02 UTC

Identified

From 02:00 UTC, we are experiencing temporary issues with the processing of BTC exchanges due to the delay of a new block of the network.

As a result, there may be delays in updating statuses on the affected exchanges page.
Once a new block is created, all deposits and exchanges will be processed as usual.

We will provide an additional update as soon as a new block is created.
Posted Nov 04, 2025 - 02:55 UTC
This incident affected: Digital Assets (Bitcoin (BTC)).