We are experiencing delays with exchanges

Incident Report for ChangeNow

Resolved

Hey!
From 21:30 yesterday to 10:30 today UTC, we experienced some delays with exchanges processing.

We're happy to let you know that the issue has now been fully resolved. Everything is back to normal, but if you're still facing any issues, please don't hesitate to reach out.

At the moment, our team is working on completing the affected exchanges. We truly apologize for any inconvenience this may have caused and appreciate your patience!
Posted Oct 11, 2025 - 10:44 UTC

Identified

Hi! From 21:30 UTC we are experiencing issues across several exchange integrations due to a sudden drop in the BTC rate. This is causing delays and interruptions in exchange operations.

Our team is actively monitoring the situation and working with our exchange partners to restore stability as soon as possible.
Posted Oct 10, 2025 - 21:42 UTC
This incident affected: Withdrawals, Deposits, and Exchange Processing.