Temporary issues with ETH payouts processing.
Incident Report for ChangeNow
Resolved
From 08:30 PM UTC on January 12 to 00:00 AM UTC on January 13 we were experiencing issues with ETH payouts processing.

We are happy to announce that the problem has been successfully resolved, and the team is processing all affected exchanges at this moment.

At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.
Posted Jan 13, 2023 - 00:09 UTC
Identified
From 08:30 PM UTC we are experiencing issues with ETH payouts processing.

As a result, users may notice that there is no status change from "sending to you" on the exchange page.

The issue occurred due to a highly increased load on the payment service, which created a queue of payouts in the coin.

We will get back to you with an update within 2 hours.
Posted Jan 12, 2023 - 20:56 UTC
This incident affected: Digital Assets (Ethereum (ETH)) and Exchange Processing.