We are experiencing issues with KAS deposits recognition.

Incident Report for ChangeNow

Resolved

From 18:45 UTC on March 21st to 06:00 UTC on March 22nd, we were experiencing issues with KAS deposits recognition.

We are happy to announce that the problem has been successfully resolved.
The issue occurred due to the overload of KAS network. At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Mar 22, 2025 - 06:05 UTC

Update

The issues with KAS deposit recognition occured due to the heavy load of kaspa network in general.
Our team is monitoring the situation at the moment. We will provide an additional notification once the situation with kaspa network is back to normal again.
Thank you for the understanding.
Posted Mar 21, 2025 - 22:41 UTC

Investigating

From 18:45 UTC we are experiencing issues with KAS deposits recognition. As a result, users may notice no status change from "waiting" on the exchange page. Our technical team is investigating the cause and working on a solution. We will get back to you with an update as soon as possible.
Posted Mar 21, 2025 - 18:49 UTC
This incident affected: Digital Assets (Kaspa (KAS)).