Delays with ADA deposits and payouts processing
Incident Report for ChangeNow
Resolved
Today from 15:10 UTC we were experiencing issues with recognizing deposits and payouts processing of ADA

We are happy to announce that the problem has been successfully resolved, and all unrecognized exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Sep 21, 2022 - 20:49 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 21, 2022 - 16:00 UTC
Identified
We are experiencing temporary delays with ADA deposits recognizing and payouts processing. Our team is already working on it, we’ll keep you updated.
Posted Sep 21, 2022 - 16:00 UTC
This incident affected: Digital Assets (Cardano (ADA)).