Temporary issues with displaying information due to an overload of services.
Incident Report for ChangeNow
Resolved
Today from 18:00 to 21:20 UTC we were experiencing temporary issues with displaying information due to an overload of services.

We are happy to announce that the issue has been successfully resolved.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Apr 17, 2024 - 21:28 UTC
Identified
From 18:00 UTC, we are experiencing temporary issues with displaying information due to an overload of services.
Due to this, the average time for providing information is longer than usual.
Our technical team is working on a solution.
We will get back to you with updates as soon as possible.
Posted Apr 17, 2024 - 19:01 UTC
This incident affected: Customer Support.