We are experiencing issues with XMR payouts processing.
Incident Report for ChangeNow
Resolved
From June 5 21:50 UTC to June 6 07:50 UTC, we were experiencing delays with XMR payouts processing.

We are happy to announce that the problem has been successfully resolved, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please, let us know.

We sincerely apologize for the inconvenience caused.
Posted Jun 06, 2024 - 07:58 UTC
Identified
From 21:50 UTC, we are experiencing issues with XMR payouts processing.

As a result, users may notice no status change from "sending to you" on the exchange page.
The issue occurred due to unscheduled maintenance on the side of our liquidity provider
Our technical team is already working on a solution.

We will get back to you with an update as soon as we get any news from the team.
Posted Jun 05, 2024 - 23:28 UTC
This incident affected: Exchange Processing and Digital Assets (Monero (XMR)).