Delays with BTC transactions due to a delay in the latest block on the network.

Incident Report for ChangeNow

Resolved

Today, between 15:15 and 16:08 UTC, we had a delay in processing BTC exchanges due to a holdup with the latest network block.
The issue causing delays with BTC payouts has been resolved. All pending transactions have now been processed successfully.

Thank you for your patience!
Posted Oct 06, 2025 - 16:09 UTC

Investigating

Hello!
We’re currently experiencing some temporary delays with BTC exchanges, starting from 15:15 UTC, due to a delay in the latest block on the network.

This means that you may notice delays in status updates on the affected exchanges page. Once the new block is created, everything will process as normal.
Posted Oct 06, 2025 - 15:15 UTC
This incident affected: Digital Assets (Bitcoin (BTC)).