Temporary issues with the conversion processing

Incident Report for ChangeNow

Resolved

From 8:05 UTC to 9:20 UTC, we experienced issues with conversion processing.

We are happy to announce that the issue has been successfully resolved. At this moment the service is working as usual, but if you are still experiencing this issue, please, let us know.
Posted Jun 19, 2026 - 09:23 UTC

Investigating

From 8:05 UTC, we are experiencing some temporary issues with conversion processing.

As a result, users and partners may encounter errors or notice that the status of their conversions is not updating.
Our technical team is investigating the cause and is already working on a solution.

We will get back to you with an update as soon as we receive it.
Posted Jun 19, 2026 - 08:30 UTC
This incident affected: Exchange Processing.