GALAERC20 exchanges processing
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Jan 11, 2023 - 13:00 UTC
Investigating
From 04:00 AM UTC, we are experiencing issues with GALAERC20 exchanges processing.
As a result, users may notice that there is no status change from "exchanging" on the exchange page.
Our technical team is investigating the cause and is already working on a solution.
We will get back to you with an update within several hours.
Posted Jan 11, 2023 - 09:05 UTC
This incident affected: Digital Assets (Gala (ERC20) (GALAERC20)).