XMR payouts processing delay

Incident Report for ChangeNow

Resolved

Today from 16:30 UTC to 19:50 UTC, we were experiencing issues with XMR payouts processing.

We are happy to announce that the issue has been successfully resolved, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please let us know.

We sincerely apologize for the inconvenience caused.
Posted May 14, 2025 - 19:54 UTC

Investigating

From 16:30 UTC we are experiencing issues with XMR payouts processing.
As a result, users may notice no status change from "sending to you" on the exchange page.

Our technical team is already working on a solution.
Posted May 14, 2025 - 17:26 UTC
This incident affected: Digital Assets (Monero (XMR)).