Temporary delays with ETHBASE payouts processing
Incident Report for ChangeNow
Resolved
Today from 18:00 UTC to 20:45 UTC we were experiencing issues with ETHBASE payouts processing

We are happy to announce that the issue has been successfully resolved, and all affected exchanges have been processed.
At the moment the service is working as usual, but if you are still experiencing this issue, please let us know.

We sincerely apologize for the inconvenience caused.
Posted Mar 28, 2024 - 20:50 UTC
Identified
From 18:00 UTC, we are experiencing delays with ETHBASE payouts processing.

As a result, users may notice no status change from "sending to you" on the exchange page.
The issue occurred due to a highly increased load on the payment service, which created a queue of payouts. Our technical team is already working on a solution.

We will get back to you with an update as soon as possible.
Posted Mar 28, 2024 - 18:26 UTC
This incident affected: Digital Assets (Ethereum (Base) (ETHBASE)).