Delays with deposits and payouts processing
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 11:18 UTC
Identified
From 10:00 AM (UTC) we are experiencing problems with recognizing users' deposits and payouts processing.
Our technical team is investigating the cause and is already working on a solution.
We will get back to you with an update within 1 hour.
Posted Sep 14, 2022 - 10:37 UTC
This incident affected: Withdrawals and Deposits.