SOL is under maintenance. Sell is temporarily unavailable.
Incident Report for ChangeNow
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 12:28 UTC
Identified
Solana (SOL) is under maintenance. Sell is temporarily unavailable.
Posted Sep 22, 2022 - 04:34 UTC
This incident affected: Digital Assets (Solana (SOL)).