Temporary delays with BTC exchanges

Incident Report for ChangeNow

Resolved

Positive update!
Today, between 06:20 and 06:40 UTC, we had a brief delay in processing BTC exchanges due to a holdup with the latest network block.

The good news is, that a new BTC block has now been created, and all affected exchanges have been processed. Everything is up and running again, but if you're still experiencing any issues, please feel free to reach out to us.

We truly apologize for any inconvenience this may have caused and appreciate your patience!
Posted Apr 07, 2025 - 06:46 UTC

Investigating

Hello!
We’re currently experiencing some temporary delays with BTC exchanges, starting from 06:20 UTC, due to a delay in the latest block on the network.

This means that you may notice delays in status updates on the affected exchanges page. Once the new block is created, everything will process as normal.

You can stay updated on the BTC network by checking this link: https://www.blockchain.com/btc/blocks?page=1.

We’ll send out another update as soon as the new block is confirmed. Thanks for your understanding!
Posted Apr 07, 2025 - 06:37 UTC
This incident affected: Digital Assets (Bitcoin (BTC)).